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1 INTRODUCTION

PC Diag is a robust, easy to use suite of diagnostic, troubleshooting and

benchmarking tools with many educational and professional test features incorporated:

configuration information, diagnostic tests, benchmark tests, and

utilities. This quick reference will help you set up and use the product.

· CD Contents. Your program CD contains all the files needed to run PC

Diag. Full help is built into the program.

· Read the built-in Help. You may also download the DOS or Windows Manuals.

PC Diag Pro DOS Manual at http://pc-diagnostics.com/documents/PCD_DOS_Manual.doc

PC Diag Pro Windows at http://pc-diagnostics.com/documents/PCD_Win_Manual.doc

PC-Diag offers several main-function menus to you, based on which version you are using, 
and which mode the system is in. Before presenting the main menu, PC-Diag will check the 
system to determine what is installed, and the screen will show what it is testing. Some 
circuit tests can cause the system to hang up during this process, and if so, the on-screen message
will show what caused the hang-up.

The application opens a main screen that is displayed on running the application immediately
after the initialization module. 

This main screen is composed of a title bar containing the application name, a workspace,
the main menu (with the following options: Files, Computer, Tests, Benchmark, Batch testing, Tools, Help)
, as well as a toolbar, in which there are listed the main actions to be performed at a certain time, along 
with the keys or combination keys associated thereof.

2 SETUP

PC Diag displays a “Start up Wizard” when you run it. 

IMPORTANT: You can choose to read the Wizard or simply exit out of the screen at any time! 
PC-Diag’s interactive wizard acts as an interface that will lead you through a complex task, 
using step-by-step dialogs. 

Wizard Step 1

The first step enables you to fill the Owner/Customer Information and Computer/Technician
Information. This information will be displayed in every log file and in the Snapshot Report. 

Wizard Step 2

To see the computer information select the Computer button. You can also view the computer
information anytime by pressing F3 when the horizontal menu is active or by selecting the
menu option: Computer ( Computer information.

Wizard Step 3

You can set a log file to store, view and print all the testing results and all the errors occurred 
in the current testing session. You can also set the log file by selecting the menu 
option: Files ( Log ( Initialize/settings.

Wizard Step 4

You can change the test settings as you desire. You can choose the number of passes, the time
limit and the number of errors allowed for any test by selecting the Test Settings button or
from the menu: Tools ( Options ( Test Settings

Wizard Step 5

You can run a Full batch test, a Quick batch test and also you can create your own batch file
or run a previously created batch file.

Wizard Step 6

You can view the log file by selecting the View button.
Wizard Step 7

You can run the following benchmarks: Processor, Coprocessor, Video, Fixed disk, CDROM
drive and Memory

3 OPERATION

PC Diag is easy and intuitive to use. Functions are available from the

main menu to examine the CONFIGURATION, run diagnostic TESTS, run BENCHMARK

tests, view the test results LOG, and perform UTILITIES functions. 

 General Process: The process of testing your computer will include changing
and/or verifying its configuration, diagnostic testing to verify it is functioning

properly, benchmark testing to evaluate its speed or performance,

and going over the results to discover the cause of problems detected. All

Using the Menu System:

 PC-Diag provides a structured menu system that is designed to
be very easy to use. The menu system consists of a menu list across the top of the screen, 
and each selection drops down a cascade of sub menus. 

-Use the Arrow keys to move the highlight bar to a selection and press Enter. 
-Press Esc to back up a selection. 
-If a screen of text is shown and more remains to be displayed, a scroll bar appears
 at the right side of the screen. Use Page or Arrow keys to scroll the text up and down on the display. 
-The bottom line on the screen shows you information or function keys to provide you with special
options for using the current context of the program. When you change menus or press special keys,
new special keys may be shown and defined with a word or two at the very bottom of the screen.
For example, the software nearly always displays F1 Help in the lower left hand corner. This is a 
prompt telling you to - Press F1 if you want help on the currently highlighted item. 
4 TESTING THE HARDWARE

IMPORTANT: In order to run a full hard drive test you must go to the settings screen and select ( 0 ), 

other wise PC Diag will default to quick test and will only randomly select sectors of the drive

for testing.
Running a batch test file:
1. Go to the Batch test and select Run Batch Test file. Select the file that you want to run, usually 
ending in .brn. If the file does not have a log file set, then you can set one from the File->Log menu.

2. Running the quick batch test file Just press the F5 key, or select to the Batch test -> Quick menu.

3.Running the full batch test file Just press the F4 key, or select to the Batch test -> Full menu.

4. Creating a custom batch test file Go to the Batch test and select Create/Edit Batch Test file. You can 
either create a new file or edit an existing batch. You can select the individual tests that you want to 
include in your batch, your custom tests, detailed devices selection, as well as the multiple test parameters
(number of passes, time limit, HDD testing time, errors accepted, pausing) and the log file options.

5. Testing components individually select the test that you want to run from Tests -> COMPONENT NAME menu.

IMPORTANT SAVING TEST RESULTS: Remember because you are using a CD you can view, but you can’t write any test results to the CD. You can save and write your test results to a USB Flash Drive, but in order to do so you must do the following. When you set up your batch test you must go to the USB Test in the PC Diag software and deselect the USB Testing. In other words make absolutely sure you do not include the USB testing when you set up your batch file. If you do not do this and run the USB test in our software it will reset all USB devices attached to the system you are running from and therefore you’ll be unable to write your results back to the drive.

In order to successfully save a log file to a USB device the following steps must be taken:
1: Please make sure your USB Flash Drive is formatted in the FAT16 File System. DOS will not "see" NTFS-formatted USB devices.

2: With the USB Flash Drive in the USB Slot, Enter your BIOS SETUP [usually by pressing DEL as the computer boots up] and check if BIOS displays the USB Flash Drive. If you can see the USB Flash Drive, then WITHOUT removing the USB Flash Drive, start the PC, and run the (PCdiag-DOS) application once you have completed testing you can save the results of the testing / log file to the USB Flash Drive.

3: If you do not see the device for any reason ... try to restart the computer with the device attached and try step 2) again. If you have repeated the steps several times and can still not see the USB Flash Drive, then there may be a problem with the USB drive you are unaware of, so replace it with a different USB Flash Drive and start over.

NOTE: DOS will never recognize a USB device if you insert it after the computer has started. You either have the USB device in the SLOT at power-on or it will not work.
 

Steps for Windows Platform (OS), how to format a USB Flash Drive 

  

NOTE: Formatting erases all the data on the drive so make sure you backup every folder and file before formatting. !! Use FAT16 formats for flash drives up to 256 MB of storage, larger drives will not work properly!!

  

1. Start your computer and plug in the flash drive in the USB port after Windows has completed loading. 

 

2. Open 'My Computer'; find the drive letter for your USB drive; right-click on its icon and click 'Format' 

 

3. Choose the File system type [FAT or FAT32] (drives larger than 2GB will only allow FAT32 option). 

 

4. Choose whether to perform a Quick Format or Full Format.  [Quick Format should suffice for most needs; Full Format is recommended for troubleshooting or when the drive has corrupt data.] 

 

5. Click 'Start' to begin the format. 

 

6. Wait until Windows has completed the format. 

 

7. Be sure to “Safely Remove Hardware” before unplugging any storage device from the USB port. 

 
Snapshot Report:
1. To view the snapshot report press F3 or select the Files -> Snapshot menu.

2. To setup snapshot parameters (Owner, Technician, Computer Information, Rating tables, 
Headings, etc), select the Tools-> Snapshot menu.
Log File:
1. To setup the log file as well as logging parameters, please select the Files->Log->initialize/settings
 menu.

2. To view the log file, select the File->Log->View menu.

3. HDD errors will additionally display on screen: There may be some limitations as to the displayed on 
screen results based on the number of batches run or on the number of errors per batch.

For example: We know that 200 errors will work for 10 batches. If there are more then this and
they do not display on screen you can find the results in the log file.

IMPORTANT: Memory errors will not display on the screen, but you can find them 
in the log file.


Settings:
1. To setup testing parameters, please select Tools->Options menu, then select Test settings.

2. To setup snapshot parameters (Owner, Technician, Computer Information, Rating tables,
 Headings, etc), select the Tools-> Snapshot menu.

Startup Parameters:
1. In order to run the software application with parameters, the user must modify the autoexec.bat 
file from the menu "Files -> Edit configuration files" or the application can run directly from DOS 
command line (ex.: pcdiag help).

2. The following is the command line format:

   PCDIAG [T:filename] [L:filename] [Q] [F] [SNAPSHOT[:filename]] [README] [HELP]

Where:

  [T:filename] - allows loading and running of a batch file (ex.: PCDIAG T: COMPLET.BRN). The 
only functional batch files are those previously created by this software application. Batch files are
created from the menu "Batch tests -> Create/Edit batch file".

    [L:filename] - test results from the session accessed by means of this parameter will be placed in the
 "filename" file (ex.: PCDIAG L:TESTS.LOG). The file extension can be any type.

    [Q] - performs a quick test for all of the computer components (ex.: PCDIAG Q)

    [F] - performs all tests that do not require interaction with the user for all the existing components
 (ex.: PCDIAG F)

 [SNAPSHOT[:filename] displays the information from the Snapshot report with either standard
 settings or those loaded from the "filename" (ex.: PCDIAG SNAPSHOT:filename). The file will be 
loaded and used only if it has been previously created by the software application. In order to create 
a snapshot settings file, press F3 when in the Snapshot report, modify settings and press 
"Save settings" or from the menu "Tools -> Snapshot settings -> Save settings".

 [README] - loads the help file under html format (ex.: PCDIAG README)

    [HELP] - displays the command line options

Tools & Benchmarks:
1. The Tools menu will offer you the following Hard drive tools:

- Park heads

- Check disk allocation

- Scan drive for bad sectors: IMPORTANT: In order to run a full hard drive test you must 
go to the settings screen and select ( 0 ), other wise PC Diag will default to quick test 
and will only randomly select sectors of the drive for testing.
-Refresh drive

-Format drive

-Refurbish drive

-DOD security erase drive data

1. You can benchmark the system performance using the Benchmark menu.

2. You can view the IRQ and DMA assignments using the File->IRQ and DMA menu. 
Also you can edit the configuration files using Files -> Edit configuration files.

· Upgrades and Support. We continually enhance PC Diag.

IMPORTANT:  If the product locks up or fails to function in your environment, please 

provide as much information as possible on the Technical Problem Report at

 http://store.pc-diagnostics.com/Articles.asp?ID=134 

We will give you prompt, courteous assistance. Thanks for evaluating our product.

